# TP-Link Omada 8-Port 2.5G L2+ Managed Switch

> Price comparison in United Kingdom (GBP). Lowest price right now: **£279.73** at PCHUB.UK, in stock. 1 offer from 1 shop. Checked 2026-10-11T21:08:20Z.

## Product
- Brand: TP-Link
- Category: [Computers & accessories](https://pricuro.com/uk/computers.md) > [Networking & Wi-Fi](https://pricuro.com/uk/computers/networking-wifi.md)
- EAN/GTIN: 4897098689523
- Page: https://pricuro.com/uk/p/tp-link-omada-8-port-2-5g-l2-managed-switch-241024
- Image: https://pricuro.com/img/241024/800/tp-link-omada-8-port-2-5g-l2-managed-switch.webp

## Offers (1, sorted by total price incl. delivery; used/refurbished last)

| # | Shop | Price | Delivery | Total | Availability | Condition | Buy |
|---|---|---|---|---|---|---|---|
| 1 | PCHUB.UK | £279.73 | see shop | – | in stock | new | https://pricuro.com/go/2282524 |

## Price history (lowest price per day in United Kingdom, tracked since 2026-10-03, 9 days)

- Lowest price today: £279.73
- Last 30 days: lowest £251.66, highest £279.73, average £258.35
- All-time low on Pricuro: £251.66 (2026-10-06)
- Note: the history is still short, so it does not yet show whether today's price is a good one.

| Date | Lowest price |
|---|---|
| 2026-10-03 | £253.02 |
| 2026-10-04 | £253.02 |
| 2026-10-05 | £253.02 |
| 2026-10-06 | £251.66 |
| 2026-10-07 | £251.66 |
| 2026-10-08 | £251.66 |
| 2026-10-09 | £251.66 |
| 2026-10-10 | £279.73 |
| 2026-10-11 | £279.73 |

## Specifications

TP-Link Omada 8-Port 2.5G L2+ Managed Switch. Switch type: Managed, Switch layer: L2+. Basic switching RJ-45 Ethernet ports type: 2.5G Ethernet (100/1000/2500), Basic switching RJ-45 Ethernet ports quantity: 8, Console port: RJ-45/micro-USB. MAC address table: 16000 entries, Switching capacity: 80 Gbit/s. Networking standards: IEEE 802.1D, IEEE 802.1s, IEEE 802.1w. Power connector: AC-in jack. Rack mounting, Form factor: 1U

- Switch type: Managed
- Switch layer: L2+
- Quality of Service (QoS) support: Yes
- Web-based management: Yes
- Cloud-managed: Yes
- Traffic classification: Yes
- ARP inspection: Yes
- Configuring Location Settings (CLI): Yes
- System event log: Yes
- MIB support: RFC2925, RFC2618, RFC2620, RFC2021, RFC2819, RFC2674, RFC1493, RFC1643, RFC2233, RFC1213
- Basic switching RJ-45 Ethernet ports quantity: 8
- Basic switching RJ-45 Ethernet ports type: 2.5G Ethernet (100/1000/2500)
- 2.5G Ethernet (copper) ports quantity: 8
- SFP+ module slots quantity: 2
- Console port: RJ-45/micro-USB
- Power connector: AC-in jack
- Networking standards: IEEE 802.1D, IEEE 802.1s, IEEE 802.1w
- 10G support: Yes
- Port mirroring: Yes
- IP routing: Yes
- Flow control support: Yes
- Link aggregation: Yes
- Broadcast storm control: Yes
- Rate limiting: Yes
- Spanning tree protocol: Yes
- Head-of-line (HOL) blocking: Yes
- Ethernet LAN data rates: 100,1000,2500 Mbit/s
- VLAN support: Yes
- Virtual LAN features: MAC address-based VLAN, Port-based VLAN, Private VLAN, Protocol-based VLAN, Tagged VLAN, Voice VLAN
- Number of VLANs: 4000

## Other variants

- [TP-Link Omada 8-Port 10GE SFP+ L2+ Managed Switch](https://pricuro.com/uk/p/tp-link-omada-8-port-10ge-sfp-l2-managed-switch-977792.md) – from £228.27
- [TP-Link Omada 16-Port 2.5G and 2-Port 10GE SFP+ L2+ Managed Switch wit](https://pricuro.com/uk/p/tp-link-omada-16-port-2-5g-and-2-port-10ge-sfp-l2-managed-switch-wit-241027.md) – from £342.15
- [TP-Link Omada 16-Port 10GE SFP+ L2+ Managed Switch](https://pricuro.com/uk/p/tp-link-omada-16-port-10ge-sfp-l2-managed-switch-977791.md) – from £451.38
- [TP-Link Omada 32-Port 10GE SFP+ L2+ Managed Switch](https://pricuro.com/uk/p/tp-link-omada-32-port-10ge-sfp-l2-managed-switch-239889.md) – from £710.24
- [TP-Link Omada Pro 24-Port PoE+ 2.5G L2+ Managed Switch with 4 SFP+ Slo](https://pricuro.com/uk/p/tp-link-omada-pro-24-port-poe-2-5g-l2-managed-switch-with-4-sfp-slo-661393.md) – from £2,734.64
- [TP-LINK ES210XPP-M2 Omada 8-Port and 2-Port Managed Switch](https://pricuro.com/uk/p/tp-link-es210xpp-m2-omada-8-port-and-2-port-managed-switch-514399.md) – from £142.67
- [TP-Link Omada 8-Port Gigabit L2+ Managed Switch with 2 SFP Slots](https://pricuro.com/uk/p/tp-link-omada-8-port-gigabit-l2-managed-switch-with-2-sfp-slots-977788.md) – from £102.68
- [TP-Link Omada 32-Port 10GE L2+ Managed Switch with 24-Port PoE++](https://pricuro.com/uk/p/tp-link-omada-32-port-10ge-l2-managed-switch-with-24-port-poe-514226.md) – from £1,492.13
- [TP-Link Omada 6-Port 10GE L2+ Managed Switch with 4-Port PoE++](https://pricuro.com/uk/p/tp-link-omada-6-port-10ge-l2-managed-switch-with-4-port-poe-977796.md) – from £445.72
- [TP-Link Omada 5-Port Gigabit Easy Managed Switch](https://pricuro.com/uk/p/tp-link-omada-5-port-gigabit-easy-managed-switch-1122082.md) – from £29.99
- [TP-Link Omada 28-Port Gigabit L2+ Managed Switch with 24-Port PoE+](https://pricuro.com/uk/p/tp-link-omada-28-port-gigabit-l2-managed-switch-with-24-port-poe-977807.md) – from £294.67

## Similar products

- [NETGEAR Orbi Dual-Band Wi-Fi 7 RBE373 Mesh System - 3 Pack](https://pricuro.com/uk/p/netgear-orbi-dual-band-wi-fi-7-rbe373-mesh-system-3-pack-443053.md) – from £274.64, 3 shops
- [TP-Link Archer 5G AX3000 Wireless Dual-Band Gigabit Router](https://pricuro.com/uk/p/tp-link-archer-5g-ax3000-wireless-dual-band-gigabit-router-514192.md) – from £269.99, 2 shops
- [ASUS RT ASUS RT-BE88U BE7200 Dual-band 5764 Mbit/s Router](https://pricuro.com/uk/p/asus-rt-asus-rt-be88u-be7200-dual-band-5764-mbit-s-router-227934.md) – from £268.58, 3 shops
- [Bosch GOF 20-12 1/2" Plunge Router](https://pricuro.com/uk/p/bosch-gof-20-12-1-2-plunge-router-7085024.md) – from £263.95, 2 shops
- [Synology DiskStation DS225+ 2 Bay NAS Desktop Intel® Celeron® J4125 2](https://pricuro.com/uk/p/synology-diskstation-ds225-2-bay-nas-desktop-intel-celeron-j4125-2-227053.md) – from £295.88, 2 shops
- [Synology HAT3300-6T NAS 6TB SATA 3.5 HDD internal hard drive 5400 RPM](https://pricuro.com/uk/p/synology-hat3300-6t-nas-6tb-sata-3-5-hdd-internal-hard-drive-5400-rpm-227011.md) – from £262.13, 3 shops

---
Source: Pricuro (https://pricuro.com), an independent price comparison for United Kingdom. Canonical page: https://pricuro.com/uk/p/tp-link-omada-8-port-2-5g-l2-managed-switch-241024
Prices include VAT and were checked at the time stated above; they can change at any moment, the shop's price at checkout applies. Links marked "Buy" lead to the shop; Pricuro may earn a commission, which never affects the order of offers (sorted by total price).
When citing, please link the canonical page. Overview of the site for assistants: https://pricuro.com/llms.txt
